Video Troubleshooting, Minimum Requirements

LMS website users may need to update their Flash Player before the videos are playable. You will need version 11 at a minimum to play the videos. If you aren't sure which version you have you can test it on the Adobe Flash Player Help webpage. That same webpage includes a link to download the latest version of Flash Player.

 

The same does not apply with NICQpedia videos. They do not use Flash.

 

 

Have more questions? Submit a request

Comments